Have a sweet ride? Tell us all about here!
  • User avatar
User avatar
By blueturbofly
Donations Avatar
#12386
washed the parts engine / trans….my pressure washer decided to not co-operate, and the pump shit the bed. little more than high pressure garden hose… :P that was a good 20 year run on a free pressure washer…..got the replacement engine / trans as clean as possible…

got the engine / trans out of the car. when i drained the trans, there were some larger chunks stuck to the magnet. this trans is most likely toast ,like the engine.

tomorrow, i will swap out head / intake / dizzy from the pulled engine , onto the core engine. separate the trans, check the clutch….i hav some good used small clutch discs / pressure plates if needed… ;-)
will install new cam and crank seals…
User avatar
By blueturbofly
Donations Avatar
#12388
Image
Image
Image
Image
Image
Image

cleaned up as best as possible. new cam, crank, rear main & trans output seals, new input shaft bearing. clutch disc is a small one, but still really good. good used timing belt, greased idler. swapped heads, small hole head gasket, new re-useable headbolts.
rad / heater core flushed, new 195 * t-stat & red delo coolant. new exhaust donut.

fired up first crank, and idle smooth as silk….no rod OR lifter noise…..NONE….swapped trans shifts really nice…
road test to work tomorrow. then change oil &filter.

i think its done!!!!! :-D :-D :-D

had the engine/ trans pulled out yesterday…we started the head swap this morning at around 10? did everything else as we went along, had it running around 5… not bad for 7 hours… ;-)
Walt liked this
User avatar
By blueturbofly
Donations Avatar
#12399
water pump leak. :-( engine oil leak :-(
water pump leaking from the weep hole. shoulda changed that…. :oops:

oil pan bolts were not very tight- snugged them up…but might just have to drop the pan and re-seal it with permatex…needs an oil change anyways…
User avatar
By blueturbofly
Donations Avatar
#12482
changed the leaking water pump. changed the engine oil & filter. didnt notice any oil leaks after snugging up the oil pan bolts….
Walt liked this
User avatar
By blueturbofly
Donations Avatar
#12492
swapped out the front rotors and pads from a parts car….actually complete knuckle assembly, it had noisy bearings as well. the front rotors were done , as well as the brake pads….very heavy corrosion and pitting on the rotors….the brakes werent very good, and they were not cleaning up from driving, so…swap stuff around….
i didnt install larger brake rotors/ calipers/ pads, like i usually do….i just cleaned up the '‘baby brakes’' from the trans donor car… buffed the rust from the rotors, lubed the caliper slide pins, and the kiddo removed / installed the parts…and of course, all torqued properly…..i dont fool around when it comes to suspension / brake work…. ;-)
gotta run to town, will see how the brakes are, and see if the bearing noise is gone….
User avatar
By blueturbofly
Donations Avatar
#12493
bearing noise is gone, brakes are 110% better….or at least as good as the little baby brakes get…. ;-)
the dash may have to come apart, the fresh / recirculate lever doesnt move the flapper….maybe thats why it was so foggy in there , last week when i drove it in the bitter cold….

get lots of stares, and thumbs up wherever i drive it…!!! :laugh:
Walt liked this
User avatar
By blueturbofly
Donations Avatar
#12519
engine has a dead spot right off throttle…..really bad when engine cold, stalls out but does not die, if you ease into the throttle its ok, when it warms up its mostly gone….no codes, i opened up the fpr and it looked ok , but that dont mean squat…will do a pressure test on the pump, that will tell me if its the pump, or fpr….
car has a weird twitch at highway speeds, almost like rear steer….will swap out the rear tires, and see if its just that…i hope…

since changing the water pump , it now has stable temps and throws good heat. the old pump leaked at the seals, therefore creating a '‘vacuum’' break , and allowing air into the system, and coolant out….and air pockets dont heat / cool like coolant does…so the temps were all over the board…
Walt liked this
User avatar
By blueturbofly
Donations Avatar
#12577
swapped out the rear tires….no more '‘rear steer’' when driving down the road :laugh:

swapped in a better spare tire….had to fix it first, but thats where my new floor mount manual tire changer came in handy- pulled the tire off of the wheel, patched the leak, replaced the leaking valve stem, and installed tire on wheel…no leaks !!!!
User avatar
By blueturbofly
Donations Avatar
#12584
wanted to replace the front signals with led ovals, but the ones i have wouldn’t work properly..so after i installed a different signal relay flasher, i just re-painted the insides of the oem incandescent housings and installed oem bulbs.
the new signal flasher is 100% compatible with led bulbs….so i can upgrade in the future a little easier…
fireflyse liked this
User avatar
By blueturbofly
Donations Avatar
#12601
put the little truck to the test…had to drag home the isuzu trooper after the trans died in the trooper….what a sight to see :laugh:

took a bit of tire spinning to get it rolling, but in the end i dragged that trooper 50 km home….in a blizzard….but it did it. i even hit 85 km/h at one point !!! ;-)
fireflyse, Walt liked this
  • 1
  • 6
  • 7
  • 8
  • 9
  • 10

Sigh After 4 weeks Suzuki Australia informed m[…]

What did you do to your Swift today

i think the older parts are mostly distributors in[…]

Breezy

Nice work Paul :-)

92 Black GT

I have been busy and have not had much time to wor[…]