Discussion on anything swift related. Got a new whip? Spotted a swift somewhere? Just want to shoot the breeze about your cars?
  • User avatar
  • User avatar
  • User avatar
  • User avatar
User avatar
By nwgeo
Posts Avatar
#14271
Too long since my last update. Been driving my 93 GT 4 hour per week at 75 to 80. It really needs a rebuild. Compression is terrible :-( , so it revs really fast when trying to start. Changed the right side drive shaft, the cv joint cover was leaking. Oil and filter change. Power washed the engine as some bad oil leaks, and kinda messy in some areas. Rocker cover leaking, I think the cam seals are leaking and then throwing it out the timing belt to the front of the engine and I think the oil pan is leaking hopefully not the rear main seal leaking. Seem to be missing the fog light switch, replaced one of the factory fog lights that was missing. I have remnants of mouse smell at times and then a cat at work marked my car :mad: A lot to do still. Oh I replaced the lug nuts that were rusty with some new black ones. a little better. :-(
Walt, DrelvisGTi liked this
User avatar
By DrelvisGTi
Posts Avatar
#14272
nwgeo wrote: Mon Jun 06, 2022 1:47 am

Too long since my last update. Been driving my 93 GT 4 hour per week at 75 to 80. It really needs a rebuild. Compression is terrible :-( , so it revs really fast when trying to start. Changed the right side drive shaft, the cv joint cover was leaking. Oil and filter change. Power washed the engine as some bad oil leaks, and kinda messy in some areas. Rocker cover leaking, I think the cam seals are leaking and then throwing it out the timing belt to the front of the engine and I think the oil pan is leaking hopefully not the rear main seal leaking. Seem to be missing the fog light switch, replaced one of the factory fog lights that was missing. I have remnants of mouse smell at times and then a cat at work marked my car :mad: A lot to do still. Oh I replaced the lug nuts that were rusty with some new black ones. a little better. :-(

Hi Mate,

This is the best post I’ve seen all year and the most honest by far…

Love it.


Cheers,

Drew
User avatar
By blueturbofly
Donations Avatar
#14319
had an odd vibe / noise when on the highway….was getting worse….pulled over, thought it was a transmission bearing, it was a loose pass front wheel :-o
tightened it back up, and kept on going…. :-D
User avatar
By blueturbofly
Donations Avatar
#14325
changed oil & filter. turned up the base idle rpm. THE PROPER WAY, I DID NOT ADJUST THE '‘ DO NOT ADJUST’' NUT/ ALLEN KEY :laugh: :laugh:

chased what i thought was a wiring issue, turns out it was a tail- light lens issue…majority of the reflective coating was missing from the one tail-light lens, making it significantly darker than the other side….sprayed some chrome paint into a little bottle, poured that into the tail-lamp lens, and the wife maneuvered it around, coating the oem reflective surfaces with fresh chrome paint….now the lens is just as bright , if not brighter, than the other side….replaced the other lens, it had a crack thru it.
i have no spare '‘metro’' tailamp assemblies, only gti and firefly/ sprint assemblies….AND ’vert metro tail lamp assemblies wont fit. they look the same, but the wiring harness lamp socket plug key-ways are different….canada built vs. japan built

changed out the stereo, the panasonic was acting up, installed a jvc unit.

found mouse chewed paper in the car, it wasnt there the day before….and the cats wouldnt leave the heater ducts alone….blew out a bunch of black foam and insulation from the floor vent…. :-o
so i put traps in there, baited with peanut butter…. :P
User avatar
By GT4LIFE
Avatar
#14326
blueturbofly wrote: Thu Jun 23, 2022 7:38 am

had an odd vibe / noise when on the highway….was getting worse….pulled over, thought it was a transmission bearing, it was a loose pass front wheel :-o
tightened it back up, and kept on going…. :-D

I had a close call like that with the rear axle nut. Working late/ tired and I forgot to torque it down. It is a good thing we know our cars. I pulled over and couldn’t believe how close I was to having a really bad day. The only tool I had on hand was a pair of pliers on my Gerber multi tool. I tightened it down as best I could and drove home slower than I have ever driven on the freeway. Good save!
Walt liked this
  • 1
  • 32
  • 33
  • 34
  • 35
  • 36
MKI Turbo Firefly

Seeking a RHB32 turbocharger in working condition.

G13B head gasket

The Suzuki MLS is one of the hardiest head gaske[…]

pontiac truck

changed a inside broken hood latch release handle.[…]

had an odd vibe / noise when on the highway....w[…]